summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 6 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 6cc7b82..f916a55 100644
--- a/configure.ac
+++ b/configure.ac
@@ -180,10 +180,12 @@ build_documentation="yes"
AC_ARG_ENABLE(documentation,
[AS_HELP_STRING(--enable-documentation, [Build documentation (no)])],
[build_documentation="$enableval"])
-AC_CHECK_PROG(HAVE_DOXYGEN, doxygen, true, false)
-if test $HAVE_DOXYGEN = "false"; then
- AC_MSG_WARN([*** Doxygen not found, API documentation will not be built])
- build_documentation="no"
+if test "$build_documentation" = "yes"; then
+ AC_CHECK_PROG(HAVE_DOXYGEN, doxygen, true, false)
+ if test $HAVE_DOXYGEN = "false"; then
+ AC_MSG_WARN([*** Doxygen not found, API documentation will not be built])
+ build_documentation="no"
+ fi
fi
AM_CONDITIONAL(HAVE_DOXYGEN, [test "x$build_documentation" = "xyes"])