summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules16
1 files changed, 8 insertions, 8 deletions
diff --git a/debian/rules b/debian/rules
index f491e73..d02b169 100755
--- a/debian/rules
+++ b/debian/rules
@@ -17,13 +17,13 @@ DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
# shared library versions, option 1
-version=2.0.5
-major=2
+#version=2.0.5
+#major=2
# option 2, assuming the library is created as src/.libs/libfoo.so.2.0.5 or so
-#version=`ls src/.libs/lib*.so.* | \
-# awk '{if (match($$0,/[0-9]+\.[0-9]+\.[0-9]+$$/)) print substr($$0,RSTART)}'`
-#major=`ls src/.libs/lib*.so.* | \
-# awk '{if (match($$0,/\.so\.[0-9]+$$/)) print substr($$0,RSTART+4)}'`
+version=`ls src/.libs/lib*.so.* | \
+ awk '{if (match($$0,/[0-9]+\.[0-9]+\.[0-9]+$$/)) print substr($$0,RSTART)}'`
+major=`ls src/.libs/lib*.so.* | \
+ awk '{if (match($$0,/\.so\.[0-9]+$$/)) print substr($$0,RSTART+4)}'`
config.status: configure
dh_testdir
@@ -63,8 +63,8 @@ install: build
dh_clean -k
dh_installdirs
- # Add here commands to install the package into debian/tmp
- $(MAKE) DESTDIR=$(CURDIR)/debian/tmp install
+ $(MAKE) DESTDIR=$(CURDIR)/debian/slv2-6 install-exec
+ $(MAKE) DESTDIR=$(CURDIR)/debian/slv2-dev install-data install-man
# Build architecture-independent files here.