summaryrefslogtreecommitdiffstats
path: root/examples/hosts/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'examples/hosts/Makefile.am')
-rw-r--r--examples/hosts/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/examples/hosts/Makefile.am b/examples/hosts/Makefile.am
new file mode 100644
index 0000000..340c962
--- /dev/null
+++ b/examples/hosts/Makefile.am
@@ -0,0 +1,24 @@
+AM_CFLAGS = -std=c99 -I. -I$(top_srcdir)/include -I$(top_srcdir) `pkg-config --cflags rasqal`
+AM_LDFLAGS = `pkg-config --libs rasqal`
+
+bin_PROGRAMS = test_host jack_host
+
+test_host_DEPENDENCIES = ../../src/libslv2.la
+test_host_LDADD = ../../src/libslv2.la
+
+test_host_SOURCES = \
+ test_host.c
+
+
+if WITH_JACK
+
+jack_host_CFLAGS = @JACK_CFLAGS@ $(AM_CFLAGS)
+#jack_host_LIBS = @JACK_LIBS@
+
+jack_host_DEPENDENCIES = ../../src/libslv2.la
+jack_host_LDADD = ../../src/libslv2.la @JACK_LIBS@
+
+jack_host_SOURCES = \
+ jack_host.c
+
+endif # WITH_JACK