summaryrefslogtreecommitdiffstats
path: root/hosts/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/Makefile.am')
-rw-r--r--hosts/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/hosts/Makefile.am b/hosts/Makefile.am
new file mode 100644
index 0000000..aa794c5
--- /dev/null
+++ b/hosts/Makefile.am
@@ -0,0 +1,18 @@
+AM_CFLAGS = -std=c99 -I$(top_srcdir) @RASQAL_CFLAGS@
+
+if WITH_JACK
+
+bin_PROGRAMS = lv2_jack_host lv2_simple_jack_host
+
+lv2_jack_host_CFLAGS = @JACK_CFLAGS@ $(AM_CFLAGS)
+
+lv2_jack_host_DEPENDENCIES = ../src/libslv2.la
+lv2_jack_host_LDADD = ../src/libslv2.la @JACK_LIBS@ @RASQAL_LIBS@
+
+lv2_simple_jack_host_LDADD = ../src/libslv2.la @JACK_LIBS@ @RASQAL_LIBS@
+
+lv2_jack_host_SOURCES = \
+ lv2_jack_host.c
+
+endif
+