summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..5f6cea2
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,14 @@
+AM_CFLAGS = -std=c99 -I$(top_srcdir)/include -I$(top_srcdir) @RASQAL_CFLAGS@ -DLIBSLV2_SOURCE
+AM_LDFLAGS = `pkg-config --libs rasqal`
+
+lib_LTLIBRARIES = libslv2.la
+libslv2_la_LIBADD = @RASQAL_LIBS@
+
+libslv2_la_SOURCES = \
+ util.h \
+ plugin.c \
+ query.c \
+ port.c \
+ pluginlist.c \
+ util.c \
+ plugininstance.c