summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2006-10-14 05:51:23 +0000
committerDavid Robillard <d@drobilla.net>2006-10-14 05:51:23 +0000
commit5cb3a78c84c5f82421825ee6de507f2cdad5f654 (patch)
treee8a17b6132c123fd4932baebc6ab7712925a3dbd /configure.ac
parent56e5e5dca5591a6901facb6d1b7a12a04a265de3 (diff)
downloadpatchage-5cb3a78c84c5f82421825ee6de507f2cdad5f654.tar.gz
patchage-5cb3a78c84c5f82421825ee6de507f2cdad5f654.tar.bz2
patchage-5cb3a78c84c5f82421825ee6de507f2cdad5f654.zip
Fixed Patchage dynamic reconnection.
git-svn-id: http://svn.drobilla.net/lad/patchage@166 a436a847-0d15-0410-975c-d299462d15a1
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4e3bedd..a3c18a4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -98,6 +98,16 @@ if test "$strict" = "yes"; then
CXXFLAGS="$CXXFLAGS -ansi -Wall -Wextra -Wno-unused-parameter -Wconversion -Winit-self -Woverloaded-virtual -Wsign-promo"
fi
+# Boost shared_ptr debugging
+pointer_debug="no"
+AC_ARG_ENABLE(pointer_debug,
+ [AS_HELP_STRING(--enable-pointer-debug, [Enable smart pointer debugging (no)])],
+ [pointer_debug="$enableval"])
+if test "$pointer_debug" = "yes"; then
+ CFLAGS+=" -DBOOST_SP_ENABLE_DEBUG_HOOKS"
+ CXXFLAGS+=" -DBOOST_SP_ENABLE_DEBUG_HOOKS"
+fi
+
# Bolt on a few specific flags to CXXFLAGS that should always be used
CXXFLAGS="$CXXFLAGS -pipe -Wall -fmessage-length=139 -fdiagnostics-show-location=every-line"
CFLAGS="$CFLAGS -pipe -Wall -fmessage-length=139 -fdiagnostics-show-location=every-line"