summaryrefslogtreecommitdiffstats
path: root/debian-sid
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2008-09-07 17:06:59 +0000
committerDavid Robillard <d@drobilla.net>2008-09-07 17:06:59 +0000
commit90bf036f8476471bfc6e1d544dae87d711a853bf (patch)
treef4c484790b5dee4847e90145a07d3c6b4181bba4 /debian-sid
parent0a033e4ebda9ce67b2eb21a72d99c60412c3068c (diff)
downloadpatchage-90bf036f8476471bfc6e1d544dae87d711a853bf.tar.gz
patchage-90bf036f8476471bfc6e1d544dae87d711a853bf.tar.bz2
patchage-90bf036f8476471bfc6e1d544dae87d711a853bf.zip
Move debian -> debian-sid.
git-svn-id: http://svn.drobilla.net/lad/patchage@1473 a436a847-0d15-0410-975c-d299462d15a1
Diffstat (limited to 'debian-sid')
-rw-r--r--debian-sid/Makefile.am8
l---------debian-sid/README1
l---------debian-sid/changelog1
-rw-r--r--debian-sid/compat1
-rw-r--r--debian-sid/control16
-rw-r--r--debian-sid/copyright34
-rw-r--r--debian-sid/docs1
-rwxr-xr-xdebian-sid/rules105
8 files changed, 167 insertions, 0 deletions
diff --git a/debian-sid/Makefile.am b/debian-sid/Makefile.am
new file mode 100644
index 0000000..757249d
--- /dev/null
+++ b/debian-sid/Makefile.am
@@ -0,0 +1,8 @@
+EXTRA_DIST = \
+ README \
+ changelog \
+ compat \
+ control \
+ copyright \
+ docs \
+ rules
diff --git a/debian-sid/README b/debian-sid/README
new file mode 120000
index 0000000..59a23c4
--- /dev/null
+++ b/debian-sid/README
@@ -0,0 +1 @@
+../README \ No newline at end of file
diff --git a/debian-sid/changelog b/debian-sid/changelog
new file mode 120000
index 0000000..22ec9b8
--- /dev/null
+++ b/debian-sid/changelog
@@ -0,0 +1 @@
+../ChangeLog \ No newline at end of file
diff --git a/debian-sid/compat b/debian-sid/compat
new file mode 100644
index 0000000..7ed6ff8
--- /dev/null
+++ b/debian-sid/compat
@@ -0,0 +1 @@
+5
diff --git a/debian-sid/control b/debian-sid/control
new file mode 100644
index 0000000..a87ec34
--- /dev/null
+++ b/debian-sid/control
@@ -0,0 +1,16 @@
+Source: patchage
+Priority: extra
+Maintainer: Dave Robillard <dave@drobilla.net>
+Build-Depends: debhelper (>= 5), autotools-dev
+Standards-Version: 3.7.3
+Section: sound
+
+Package: patchage
+Section: sound
+Architecture: any
+Pre-Depends: make
+Depends: ${shlibs:Depends}, raul-0, flowcanvas-0
+Description: A modular patch bay for audio and MIDI
+ Patchage is a modular patch bay for audio and MIDI systems
+ based on JACK (audio, MIDI), LASH (projects), and ALSA (MIDI).
+
diff --git a/debian-sid/copyright b/debian-sid/copyright
new file mode 100644
index 0000000..97ef279
--- /dev/null
+++ b/debian-sid/copyright
@@ -0,0 +1,34 @@
+This package was debianized by Dave Robillard <dave@drobilla.net> on
+Wed, 14 Nov 2007 22:29:49 -0500.
+
+It was downloaded from <http://drobilla.net/software/slv2>
+
+Upstream Author:
+
+ Dave Robillard <dave@drobilla.net>
+
+Copyright:
+
+ Copyright (C) 2007 Dave Robillard
+
+License:
+
+ This package is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 2 of the License, or
+ (at your option) any later version.
+
+ This package is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this package; if not, write to the Free Software
+ Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
+
+On Debian systems, the complete text of the GNU General
+Public License can be found in `/usr/share/common-licenses/GPL'.
+
+The Debian packaging is (C) 2007, Dave Robillard <dave@drobilla.net> and
+is licensed under the GPL, see above.
diff --git a/debian-sid/docs b/debian-sid/docs
new file mode 100644
index 0000000..e845566
--- /dev/null
+++ b/debian-sid/docs
@@ -0,0 +1 @@
+README
diff --git a/debian-sid/rules b/debian-sid/rules
new file mode 100755
index 0000000..3c586a1
--- /dev/null
+++ b/debian-sid/rules
@@ -0,0 +1,105 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+# Sample debian/rules that uses debhelper.
+# This file was originally written by Joey Hess and Craig Small.
+# As a special exception, when this file is copied by dh-make into a
+# dh-make output file, you may use that output file without restriction.
+# This special exception was added by Craig Small in version 0.37 of dh-make.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+
+# These are used for cross-compiling and for saving the configure script
+# from having to guess our platform (since we know it already)
+DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
+DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+
+
+# shared library versions, option 1
+#version=2.0.5
+#major=2
+# option 2, assuming the library is created as src/.libs/libfoo.so.2.0.5 or so
+version=`ls src/.libs/lib*.so.* | \
+ awk '{if (match($$0,/[0-9]+\.[0-9]+\.[0-9]+$$/)) print substr($$0,RSTART)}'`
+major=`ls src/.libs/lib*.so.* | \
+ awk '{if (match($$0,/\.so\.[0-9]+$$/)) print substr($$0,RSTART+4)}'`
+
+config.status: configure
+ dh_testdir
+ # Add here commands to configure the package.
+ifneq "$(wildcard /usr/share/misc/config.sub)" ""
+ cp -f /usr/share/misc/config.sub config.sub
+endif
+ifneq "$(wildcard /usr/share/misc/config.guess)" ""
+ cp -f /usr/share/misc/config.guess config.guess
+endif
+ ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info CFLAGS="$(CFLAGS)" LDFLAGS="-Wl,-z,defs"
+
+
+build: build-stamp
+build-stamp: config.status
+ dh_testdir
+
+ # Add here commands to compile the package.
+ $(MAKE)
+
+ touch $@
+
+clean:
+ dh_testdir
+ dh_testroot
+ rm -f build-stamp
+
+ # Add here commands to clean up after the build process.
+ $(MAKE) distclean
+ rm -f config.sub config.guess
+
+ dh_clean
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+
+ $(MAKE) DESTDIR=$(CURDIR)/debian/patchage install-exec install-data
+
+
+# Build architecture-independent files here.
+binary-indep: build install
+ dh_installman
+
+# Build architecture-dependent files here.
+binary-arch: build install
+ dh_testdir
+ dh_testroot
+ dh_installchangelogs
+ dh_installdocs
+ dh_installexamples
+# dh_install
+# dh_installmenu
+# dh_installdebconf
+# dh_installlogrotate
+# dh_installemacsen
+# dh_installpam
+# dh_installmime
+# dh_installinit
+# dh_installcron
+# dh_installinfo
+# dh_installman
+ dh_link
+ dh_strip
+ dh_compress
+ dh_fixperms
+# dh_perl
+# dh_python
+ dh_makeshlibs
+ dh_installdeb
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install