summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 8 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 43c8232..82b1756 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,4 +1,4 @@
-SUBDIRS = src icons debian
+SUBDIRS = src icons debian-sid
desktopfilesdir = $(datadir)/applications
dist_desktopfiles_DATA = patchage.desktop
@@ -7,4 +7,10 @@ docs: Doxyfile src/*.h src/*.cpp
doxygen
deb:
- dpkg-buildpackage -sn
+ if [ -e debian ]; then \
+ echo "ERROR: ./debian exists, you must move it out of the way."; \
+ else \
+ ln -s debian-sid debian; \
+ dpkg-buildpackage -sn; \
+ rm debian; \
+ fi