summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 4 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index dfb41f1..31199eb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -34,13 +34,12 @@ if test "$build_jack_midi" = "yes"; then
fi
# Check for ALSA
-enable_alsa="yes"
+build_alsa="yes"
AC_ARG_ENABLE(alsa,
[AS_HELP_STRING(--enable-alsa, [Enable Alsa MIDI driver (yes)])],
-[ enable_alsa="$enableval" ]
-)
+ [ if test x$enable_alsa = xno ; then build_alsa=no ; fi ])
-if test "$enable_alsa" = "yes"; then
+if test "$build_alsa" = "yes"; then
AC_CHECK_LIB(asound, snd_seq_open, ALSA_FOUND="yes", ALSA_FOUND="no", -lm -ldl -lpthread)
if test "$ALSA_FOUND" = "yes"; then
@@ -126,7 +125,7 @@ AC_MSG_RESULT([])
AC_MSG_RESULT([**********************************************************************])
AC_MSG_RESULT([Patchage build configuration:])
AC_MSG_RESULT([])
-AC_MSG_RESULT([Alsa support: $ALSA_FOUND])
+AC_MSG_RESULT([Alsa support: $build_alsa])
AC_MSG_RESULT([Lash support: $have_lash])
AC_MSG_RESULT([**********************************************************************])
AC_MSG_RESULT([])