summaryrefslogtreecommitdiffstats
path: root/raul/Makefile.am
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2007-07-26 11:29:31 +0000
committerDavid Robillard <d@drobilla.net>2007-07-26 11:29:31 +0000
commit47fb95d6086c2c67086316a25b4c0858783d3c2b (patch)
tree4ac9934f1f38b0b6ed42f41b2bd9d7cdbc90c2f8 /raul/Makefile.am
parent25b9a123b60f769506a829542d05f38b1e95d51b (diff)
downloadraul-47fb95d6086c2c67086316a25b4c0858783d3c2b.tar.gz
raul-47fb95d6086c2c67086316a25b4c0858783d3c2b.tar.bz2
raul-47fb95d6086c2c67086316a25b4c0858783d3c2b.zip
Added PathTable, simple pretty wrapper around Table which provides super fast
"find all descendants". I couldn't deal with the 'one big table' or 'parents own/lookup children' decision, so I came up with this thing instead. It's pretty cool I guess. git-svn-id: http://svn.drobilla.net/lad/raul@635 a436a847-0d15-0410-975c-d299462d15a1
Diffstat (limited to 'raul/Makefile.am')
-rw-r--r--raul/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/raul/Makefile.am b/raul/Makefile.am
index 7f47a50..cd44b73 100644
--- a/raul/Makefile.am
+++ b/raul/Makefile.am
@@ -13,6 +13,7 @@ raulinclude_HEADERS = \
Maid.hpp \
Namespaces.hpp \
Path.hpp \
+ PathTable.hpp \
Process.hpp \
Quantizer.hpp \
RDFModel.hpp \