summaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2007-01-06 19:39:56 +0000
committerDavid Robillard <d@drobilla.net>2007-01-06 19:39:56 +0000
commit4014067a1668d94000b059d72832482a06cf8369 (patch)
tree7617295999221d85fb5fdf6ac92f30beba4141da /tests/Makefile.am
parent1a2962681ff62598f6cbe9aed9c5d4c69c0020a6 (diff)
downloadraul-4014067a1668d94000b059d72832482a06cf8369.tar.gz
raul-4014067a1668d94000b059d72832482a06cf8369.tar.bz2
raul-4014067a1668d94000b059d72832482a06cf8369.zip
Added ability to get Raul Thread for current calling context.
Strong threading assertions. Flowcanvas port removal fixes. Patch port destruction. Code cleanups, bug fixes. git-svn-id: http://svn.drobilla.net/lad/raul@234 a436a847-0d15-0410-975c-d299462d15a1
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 0732d07..2389628 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,8 +1,12 @@
if BUILD_TESTS
-AM_CXXFLAGS = -I..
-bin_PROGRAMS = path_test
+AM_CXXFLAGS = -I.. -lpthread
+bin_PROGRAMS = path_test thread_test queue_test
+
+thread_test_LDADD = ../src/libraul.la
path_test_SOURCES = path_test.cpp
+thread_test_SOURCES = thread_test.cpp
+queue_test_SOURCES = queue_test.cpp
endif