summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 6 insertions, 15 deletions
diff --git a/configure.ac b/configure.ac
index fe8b7fb..f663a8b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -144,22 +144,13 @@ AM_CONDITIONAL(BUILD_UNIT_TESTS, [test "$build_unit_tests" = "yes"])
################## RAUL
-# Check for Redland
-#PKG_CHECK_MODULES(REDLAND, redland >= 1.0.0)
-# No pkg-config?! Booo!
-build_redland="no"
-AC_CHECK_PROG(REDLAND_CONFIG, redland-config, redland-config)
-if test "X$REDLAND_CONFIG" = X; then
- AC_MSG_ERROR([RAUL requires Redland (librdf), but redland-config not found.])
-else
- build_redland="yes"
- REDLAND_CFLAGS=`$REDLAND_CONFIG --cflags`
- REDLAND_LIBS=`$REDLAND_CONFIG --libs`
- AC_SUBST(REDLAND_CFLAGS)
- AC_SUBST(REDLAND_LIBS)
-fi
-AM_CONDITIONAL(WITH_REDLAND, [test "$build_redland" = "yes"])
+# Check for Redlandmm
+build_redlandmm="no"
+PKG_CHECK_MODULES([REDLANDMM], [redlandmm], [build_redlandmm="yes"])
+AM_CONDITIONAL(WITH_REDLANDMM, [test "$build_redlandmm" = "yes"])
+AC_DEFINE(HAVE_REDLANDMM, 1, [Has redlandmm])
+# Check for liblo
build_liblo="yes"
AC_ARG_ENABLE(liblo,
[AS_HELP_STRING(--enable-liblo, [Include liblo (OSC) support (yes)])],