summaryrefslogtreecommitdiffstats
path: root/test/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build10
1 files changed, 10 insertions, 0 deletions
diff --git a/test/meson.build b/test/meson.build
index 8411377..c134067 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -11,6 +11,16 @@ if not get_option('tests').disabled() and not meson.is_subproject()
suite: 'data',
)
endif
+
+ # Check licensing metadata
+ reuse = find_program('reuse', required: false)
+ if reuse.found()
+ test(
+ 'REUSE', reuse,
+ args: ['--root', raul_src_root, 'lint'],
+ suite: 'data',
+ )
+ endif
endif
###################