summaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am10
1 files changed, 6 insertions, 4 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 6cb5a59..20209d3 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,11 +1,13 @@
if BUILD_TESTS
-AM_CXXFLAGS = -I.. -lpthread
+AM_CXXFLAGS = -I.. -lpthread @RASQAL_CFLAGS@
+ALL_LIBS = @RASQAL_LIBS@ ../src/libraul.la
+
bin_PROGRAMS = path_test thread_test queue_test
-thread_test_LDADD = ../src/libraul.la
-path_test_LDADD = ../src/libraul.la
-queue_test_LDADD = ../src/libraul.la
+thread_test_LDADD = $(ALL_LIBS)
+path_test_LDADD = $(ALL_LIBS)
+queue_test_LDADD = $(ALL_LIBS)
path_test_SOURCES = path_test.cpp
thread_test_SOURCES = thread_test.cpp