aboutsummaryrefslogtreecommitdiffstats
path: root/doc/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2021-01-09 19:17:31 +0100
committerDavid Robillard <d@drobilla.net>2022-01-13 15:18:17 -0500
commit7d2183d13b298f33733e67184dd86a34a71723bf (patch)
treebcc350350d64ebe31d18403df497fffe398f0070 /doc/meson.build
parent17357d578b14111ce694f8af8d70e7c65c863ad3 (diff)
downloadserd-7d2183d13b298f33733e67184dd86a34a71723bf.tar.gz
serd-7d2183d13b298f33733e67184dd86a34a71723bf.tar.bz2
serd-7d2183d13b298f33733e67184dd86a34a71723bf.zip
Switch to Meson
Diffstat (limited to 'doc/meson.build')
-rw-r--r--doc/meson.build17
1 files changed, 17 insertions, 0 deletions
diff --git a/doc/meson.build b/doc/meson.build
new file mode 100644
index 00000000..5555cfbb
--- /dev/null
+++ b/doc/meson.build
@@ -0,0 +1,17 @@
+docdir = get_option('datadir') / 'doc'
+
+doxygen = find_program('doxygen', required: get_option('docs'))
+dox_to_sphinx = find_program('../scripts/dox_to_sphinx.py')
+sphinx_build = find_program('sphinx-build', required: get_option('docs'))
+
+build_docs = doxygen.found() and sphinx_build.found()
+
+if build_docs
+ subdir('_static')
+ subdir('c')
+endif
+
+if not meson.is_subproject() and meson.version().version_compare('>=0.53.0')
+ summary('Documentation', build_docs, bool_yn: true)
+endif
+