aboutsummaryrefslogtreecommitdiffstats
path: root/doc/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2021-01-09 19:17:31 +0100
committerDavid Robillard <d@drobilla.net>2021-03-07 15:32:23 -0500
commitb9d0b9f058807d7253e88d37822c47b5462b65ea (patch)
tree680357643905465c27857a1f3709ce3518ad7f82 /doc/meson.build
parent4c663def32cb6c360ab3d9e2f101c903583d1486 (diff)
downloadserd-b9d0b9f058807d7253e88d37822c47b5462b65ea.tar.gz
serd-b9d0b9f058807d7253e88d37822c47b5462b65ea.tar.bz2
serd-b9d0b9f058807d7253e88d37822c47b5462b65ea.zip
WIP: Switch to Meson
Diffstat (limited to 'doc/meson.build')
-rw-r--r--doc/meson.build17
1 files changed, 17 insertions, 0 deletions
diff --git a/doc/meson.build b/doc/meson.build
new file mode 100644
index 00000000..1ca1aef0
--- /dev/null
+++ b/doc/meson.build
@@ -0,0 +1,17 @@
+docdir = get_option('datadir') / 'doc'
+
+doxygen = find_program('doxygen', required: get_option('docs'))
+dox_to_sphinx = find_program('../scripts/dox_to_sphinx.py')
+sphinx_build = find_program('sphinx-build', required: get_option('docs'))
+
+build_docs = doxygen.found() and sphinx_build.found()
+
+if build_docs
+ subdir('_static')
+ subdir('c')
+endif
+
+if meson.version().version_compare('>=0.53.0')
+ summary('Documentation', build_docs, bool_yn: true)
+endif
+