aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2021-10-09 15:48:18 -0400
committerDavid Robillard <d@drobilla.net>2022-01-28 21:57:29 -0500
commitea272b5e88c02117a2a3ef7e12d221bd196844dc (patch)
tree0ca284906b5c9678aee541e827a9ceb002d022c0 /meson.build
parenta9f6180de5124f699963bd007daa810868f2c75a (diff)
downloadserd-ea272b5e88c02117a2a3ef7e12d221bd196844dc.tar.gz
serd-ea272b5e88c02117a2a3ef7e12d221bd196844dc.tar.bz2
serd-ea272b5e88c02117a2a3ef7e12d221bd196844dc.zip
Isolate man pages and build HTML versions with mandoc if possible
The HTML versions are mainly useful for generating the online documentation as part of a CI pipeline. They are installed anyway, which is redundant for systems with a man page reader, but handy elsewhere.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 3 insertions, 6 deletions
diff --git a/meson.build b/meson.build
index 63a9ece5..352c1734 100644
--- a/meson.build
+++ b/meson.build
@@ -140,6 +140,9 @@ if host_machine.system() != 'windows'
]
endif
+# Programs used by the build
+mandoc = find_program('mandoc', required: false)
+
# Determine library type and the flags needed to build it
library_name = versioned_name
if get_option('default_library') == 'both'
@@ -243,12 +246,6 @@ pkg.generate(
# Build command line tools
if get_option('tools')
subdir('tools')
-
- if not get_option('docs').disabled()
- install_man('doc/serd-filter.1')
- install_man('doc/serd-pipe.1')
- install_man('doc/serd-sort.1')
- endif
endif
# Install header to a versioned include directory