aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2023-09-23 17:54:45 -0400
committerDavid Robillard <d@drobilla.net>2023-09-23 17:59:26 -0400
commit1d2f4ef5a8b05698e33ce8dd87d01c091d38c7b2 (patch)
treecc4b97ca3bcac5d6116d318414250843f7f8f70c /meson.build
parenta20595e543a7c6070f7e8453adfbbc3cfab32a52 (diff)
downloadserd-1d2f4ef5a8b05698e33ce8dd87d01c091d38c7b2.tar.gz
serd-1d2f4ef5a8b05698e33ce8dd87d01c091d38c7b2.tar.bz2
serd-1d2f4ef5a8b05698e33ce8dd87d01c091d38c7b2.zip
Avoid use of deprecated meson string formatting with files
Meson annoyingly doesn't provide access to the path of file objects (but it should). It was possible to do that by formatting a string with a file argument, but now this triggers a loud warning that claims it has always been broken and will be deprecated. So, avoid this by juggling things around and maintaining unchecked path strings instead, and hope that they're all passed to files() at some point so they can't get stale.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build14
1 files changed, 0 insertions, 14 deletions
diff --git a/meson.build b/meson.build
index f50c8f52..be430a13 100644
--- a/meson.build
+++ b/meson.build
@@ -222,20 +222,6 @@ endif
# Support #
###########
-ttl_metadata_files = files(
- 'test/extra/abbreviate/manifest.ttl',
- 'test/extra/bad/manifest.ttl',
- 'test/extra/big/manifest.ttl',
- 'test/extra/good/manifest.ttl',
- 'test/extra/lax/manifest.ttl',
- 'test/extra/perfect/manifest.ttl',
- 'test/extra/prefix/manifest.ttl',
- 'test/extra/pretty/manifest.ttl',
- 'test/extra/qualify/manifest.ttl',
- 'test/extra/root/manifest.ttl',
- 'serd.ttl',
-)
-
subdir('scripts')
if not get_option('tests').disabled()