aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2020-11-10 09:45:15 +0100
committerDavid Robillard <d@drobilla.net>2022-01-13 23:05:22 -0500
commitf7d10ea309fb52d09a58b2832fe4a09a120b16aa (patch)
tree3b5d870063d0565ac29334ffb64363fdac23b012 /meson.build
parentb9cc3b642a9365c033c1fa31458d7822b42d0913 (diff)
downloadserd-f7d10ea309fb52d09a58b2832fe4a09a120b16aa.tar.gz
serd-f7d10ea309fb52d09a58b2832fe4a09a120b16aa.tar.bz2
serd-f7d10ea309fb52d09a58b2832fe4a09a120b16aa.zip
Add serd_canonical_path()
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 4 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 90f59e9b..cdc35ffc 100644
--- a/meson.build
+++ b/meson.build
@@ -109,7 +109,10 @@ m_dep = cc.find_library('m', required: false)
# System defines needed to expose platform APIs
platform_args = []
if host_machine.system() != 'windows'
- platform_args += ['-D_POSIX_C_SOURCE=200809L']
+ platform_args += [
+ '-D_POSIX_C_SOURCE=200809L',
+ '-D_XOPEN_SOURCE=600',
+ ]
endif
# Determine library type and the flags needed to build it