aboutsummaryrefslogtreecommitdiffstats
path: root/test/lax/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2021-10-21 15:38:10 -0400
committerDavid Robillard <d@drobilla.net>2022-01-28 21:57:07 -0500
commitb404312686874e539b617d1f27ccbaa5a82936af (patch)
treec2fdb2cc046e6da53071629cd1750dcc327e6cd9 /test/lax/meson.build
parentd4aec28ba8ad24d5aef3ee12beeb1b805148eab1 (diff)
downloadserd-b404312686874e539b617d1f27ccbaa5a82936af.tar.gz
serd-b404312686874e539b617d1f27ccbaa5a82936af.tar.bz2
serd-b404312686874e539b617d1f27ccbaa5a82936af.zip
Replace serdi with more fine-grained tools
Especially with the new functionality, the complexity of the command-line interface alone was really becoming unmanageable. The serdi implementation also had the highest cyclomatic complexity of the entire codebase by a huge margin. So, take a page from the Unix philosophy and split serdi into several more finely-honed tools that can be freely composed. Though there is still unfortunately quite a bit of option overlap between them due to the common details of reading RDF, I think the resulting tools are a lot easier to understand, both from a user and a developer perspective.
Diffstat (limited to 'test/lax/meson.build')
-rw-r--r--test/lax/meson.build13
1 files changed, 6 insertions, 7 deletions
diff --git a/test/lax/meson.build b/test/lax/meson.build
index 6d4d7903..e71a677c 100644
--- a/test/lax/meson.build
+++ b/test/lax/meson.build
@@ -4,8 +4,8 @@ base_uri = 'http://drobilla.net/sw/serd/test/lax/'
# ... once with strict parsing to test the hard errors
test('lax.strict',
- run_test_suite,
- args: script_args + [files('manifest.ttl'), base_uri],
+ run_pipe_suite,
+ args: pipe_test_script_args + [files('manifest.ttl'), base_uri],
env: test_env,
is_parallel: false,
suite: ['suite', 'extra'],
@@ -13,14 +13,13 @@ test('lax.strict',
# ... and once with lax parsing to tolerate them
test('lax.lax',
- run_test_suite,
- args: script_args + [
+ run_pipe_suite,
+ args: pipe_test_script_args + [
files('manifest.ttl'),
base_uri,
'--',
- '-i',
- 'lax',
- ],
+ '-I', 'lax',
+ '-O', 'lax'],
env: test_env,
is_parallel: false,
suite: ['suite', 'extra'],