aboutsummaryrefslogtreecommitdiffstats
path: root/test/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2021-10-09 13:44:31 -0400
committerDavid Robillard <d@drobilla.net>2022-01-28 21:57:07 -0500
commitcbf01be4126cbc0f6d80364a7e0b6ad777a7d8ae (patch)
tree20cd2919e0d4c47caa346123c5701daa70a05ac3 /test/meson.build
parent5ea7c0d763685c23dc6933e273dfa11eec5bec14 (diff)
downloadserd-cbf01be4126cbc0f6d80364a7e0b6ad777a7d8ae.tar.gz
serd-cbf01be4126cbc0f6d80364a7e0b6ad777a7d8ae.tar.bz2
serd-cbf01be4126cbc0f6d80364a7e0b6ad777a7d8ae.zip
Fix handling of deferred write errors that happen when closing
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/test/meson.build b/test/meson.build
index ae66ba37..a25ac6de 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -52,6 +52,7 @@ if autoship.found()
endif
serd_ttl = files('../serd.ttl')[0]
+small_ttl = files('../test/TurtleTests/turtle-syntax-number-01.ttl')[0]
common_script_options = []
if wrapper != ''
common_script_options = ['--wrapper', wrapper]
@@ -230,6 +231,11 @@ if is_variable('serd_pipe')
env: test_env,
suite: ['tools', 'pipe', 'output'])
+ test('deferred_write_error', files('test_deferred_write_error.py'),
+ args: pipe_test_script_args + [small_ttl],
+ env: test_env,
+ suite: ['tools', 'pipe', 'output'])
+
test('missing_output',
tool,
args: ['-o', '/does/not/exist.ttl', meson.source_root() / 'serd.ttl'],