aboutsummaryrefslogtreecommitdiffstats
path: root/test/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2020-11-09 14:07:46 +0100
committerDavid Robillard <d@drobilla.net>2021-03-08 23:35:30 -0500
commit7efaf2431b9c1a96f6ed2e28626aff4886efc749 (patch)
treeba84dfdb11c4e952ff39621a9b8fcf834e9592a5 /test/meson.build
parent1ba44998b0c5b8d76d574531d60b703ad56a2c8a (diff)
downloadserd-7efaf2431b9c1a96f6ed2e28626aff4886efc749.tar.gz
serd-7efaf2431b9c1a96f6ed2e28626aff4886efc749.tar.bz2
serd-7efaf2431b9c1a96f6ed2e28626aff4886efc749.zip
Add validation to command line interface
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build18
1 files changed, 18 insertions, 0 deletions
diff --git a/test/meson.build b/test/meson.build
index 84045225..87b77334 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -1,5 +1,6 @@
autoship = find_program('autoship', required: false)
run_test_suite = find_program('run_test_suite.py')
+run_validation_test_suite = find_program('run_validation_test_suite.py')
wrapper = meson.get_cross_property('wrapper', '')
unit_tests = [
@@ -158,6 +159,8 @@ if get_option('utils')
timeout: 240)
endforeach
+ manifest = files('terse' / 'manifest.ttl')
+ base_uri = serd_base + 'terse' + '/'
test('terse', run_test_suite,
args: script_args + ['--osyntax', 'turtle', manifest, base_uri, '--', '-t'],
suite: ['rdf', 'serd'],
@@ -178,6 +181,21 @@ if get_option('utils')
suite: ['rdf', 'serd'],
timeout: 240)
+ # Validation test suite
+ manifest = files('validate' / 'manifest.ttl')
+ base_uri = serd_base + 'validate' + '/'
+ test('validate', run_validation_test_suite,
+ args: script_args + [
+ manifest,
+ base_uri,
+ meson.current_source_dir() / '../schemas/owl.ttl',
+ meson.current_source_dir() / '../schemas/rdf.ttl',
+ meson.current_source_dir() / '../schemas/rdfs.ttl',
+ meson.current_source_dir() / '../schemas/xsd.ttl',
+ ],
+ suite: ['rdf', 'serd'],
+ timeout: 240)
+
## Standard W3C test suites
w3c_suites = ['Turtle', 'NTriples', 'NQuads', 'TriG']