aboutsummaryrefslogtreecommitdiffstats
path: root/test/meson.build
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2023-04-03 09:00:23 -0400
committerDavid Robillard <d@drobilla.net>2023-04-06 07:19:10 -0400
commitf905bd8e17bfcee7240ee3174f5ed420043c8bad (patch)
tree0da35aa95bee7e21314af5cfdc5683d252efe009 /test/meson.build
parent92f7c078250df898b24fce3af1ed6a9ae7d0c029 (diff)
downloadserd-f905bd8e17bfcee7240ee3174f5ed420043c8bad.tar.gz
serd-f905bd8e17bfcee7240ee3174f5ed420043c8bad.tar.bz2
serd-f905bd8e17bfcee7240ee3174f5ed420043c8bad.zip
Use new meson strict warning system
Meson includes warning_level=everything as of version 1.0.0, which supercedes maintaining redundant lists of warning flags here.
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build32
1 files changed, 13 insertions, 19 deletions
diff --git a/test/meson.build b/test/meson.build
index 45173690..283ce3e8 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -5,11 +5,20 @@ run_suite = find_program('run_suite.py')
wrapper = meson.get_external_property('exe_wrapper', '')
-####################
-# Project Metadata #
-####################
+########################
+# Scripts and Metadata #
+########################
-if get_option('strict')
+python_scripts = files(
+ '../scripts/serd_bench.py',
+ 'run_suite.py',
+ 'serd_test_util/__init__.py',
+ 'test_quiet.py',
+ 'test_stdin.py',
+ 'test_write_error.py',
+)
+
+if get_option('lint')
# Check release metadata
if not meson.is_subproject()
autoship = find_program('autoship', required: false)
@@ -28,22 +37,7 @@ if get_option('strict')
suite: 'data',
)
endif
-endif
-
-###########
-# Scripts #
-###########
-
-python_scripts = files(
- '../scripts/serd_bench.py',
- 'run_suite.py',
- 'serd_test_util/__init__.py',
- 'test_quiet.py',
- 'test_stdin.py',
- 'test_write_error.py',
-)
-if get_option('strict')
# Check script formatting
black = find_program('black', required: false)
if black.found()