aboutsummaryrefslogtreecommitdiffstats
path: root/doc/c/xml/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'doc/c/xml/meson.build')
-rw-r--r--doc/c/xml/meson.build19
1 files changed, 19 insertions, 0 deletions
diff --git a/doc/c/xml/meson.build b/doc/c/xml/meson.build
new file mode 100644
index 00000000..b9087439
--- /dev/null
+++ b/doc/c/xml/meson.build
@@ -0,0 +1,19 @@
+doxygen = find_program('doxygen')
+
+c_doxygen_input = []
+foreach h : c_headers
+ c_doxygen_input += ['..' / h]
+endforeach
+
+config = configuration_data()
+config.set('SERD_SRCDIR', serd_src_root)
+config.set('DOX_OUTPUT', meson.current_build_dir() / '..')
+
+c_doxyfile = configure_file(configuration: config,
+ input: files('../Doxyfile.in'),
+ output: 'Doxyfile')
+
+c_index_xml = custom_target('serd-c-index.xml',
+ command: [doxygen, '@INPUT0@'],
+ input: [c_doxyfile] + c_header_files,
+ output: 'index.xml')