aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 4 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 90f59e9b..cdc35ffc 100644
--- a/meson.build
+++ b/meson.build
@@ -109,7 +109,10 @@ m_dep = cc.find_library('m', required: false)
# System defines needed to expose platform APIs
platform_args = []
if host_machine.system() != 'windows'
- platform_args += ['-D_POSIX_C_SOURCE=200809L']
+ platform_args += [
+ '-D_POSIX_C_SOURCE=200809L',
+ '-D_XOPEN_SOURCE=600',
+ ]
endif
# Determine library type and the flags needed to build it