aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build16
1 files changed, 10 insertions, 6 deletions
diff --git a/meson.build b/meson.build
index 2708b5a7..301b65ac 100644
--- a/meson.build
+++ b/meson.build
@@ -30,9 +30,6 @@ if get_option('strict')
if cc.get_id() == 'clang'
c_suppressions += [
'-Wno-cast-align',
- '-Wno-cast-qual',
- '-Wno-conversion',
- '-Wno-double-promotion',
'-Wno-format-nonliteral',
'-Wno-nullability-extension',
'-Wno-nullable-to-nonnull-conversion',
@@ -43,7 +40,6 @@ if get_option('strict')
elif cc.get_id() == 'gcc'
c_suppressions += [
'-Wno-cast-align',
- '-Wno-cast-qual',
'-Wno-float-conversion', # MinGW
'-Wno-format-nonliteral',
'-Wno-inline',
@@ -135,9 +131,17 @@ elif get_option('default_library') == 'shared'
else
prog_args = ['-DSERD_STATIC']
library_type = 'static_library'
- library_args = ['-DSERD_INTERNAL', '-DSERD_STATIC']
+ library_args = [
+ '-DEXESS_STATIC',
+ '-DSERD_INTERNAL',
+ '-DSERD_STATIC',
+ ]
endif
+exess_dep = dependency('exess-0',
+ version: '>= 0.0.1',
+ fallback: ['exess', 'exess_dep'])
+
# Build shared and/or static library/libraries
libserd = build_target(
library_name,
@@ -145,7 +149,7 @@ libserd = build_target(
version: meson.project_version(),
include_directories: include_directories(['include']),
c_args: c_warnings + platform_args + library_args,
- dependencies: m_dep,
+ dependencies: [exess_dep, m_dep],
gnu_symbol_visibility: 'hidden',
install: true,
target_type: library_type)