aboutsummaryrefslogtreecommitdiffstats
path: root/meson/suppressions/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson/suppressions/meson.build')
-rw-r--r--meson/suppressions/meson.build13
1 files changed, 11 insertions, 2 deletions
diff --git a/meson/suppressions/meson.build b/meson/suppressions/meson.build
index f722ebe0..098f7ab5 100644
--- a/meson/suppressions/meson.build
+++ b/meson/suppressions/meson.build
@@ -60,16 +60,25 @@ if is_variable('cc')
'/wd4061', # enumerator in switch is not explicitly handled
'/wd4365', # signed/unsigned mismatch
'/wd4514', # unreferenced inline function has been removed
- '/wd4706', # assignment within conditional expression
'/wd4710', # function not inlined
'/wd4711', # function selected for automatic inline expansion
'/wd4800', # implicit conversion from int to bool
'/wd4820', # padding added after construct
- '/wd4996', # POSIX name for this item is deprecated
'/wd5045', # will insert Spectre mitigation for memory load
]
endif
endif
+ if cc.get_id() == 'clang'
+ c_suppressions += [
+ '-Wno-nullability-extension',
+ ]
+ elif cc.get_id() == 'msvc'
+ c_suppressions += [
+ '/wd4706', # assignment within conditional expression
+ '/wd4996', # POSIX name for this item is deprecated
+ ]
+ endif
+
c_suppressions = cc.get_supported_arguments(c_suppressions)
endif