aboutsummaryrefslogtreecommitdiffstats
path: root/test/headers/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test/headers/meson.build')
-rw-r--r--test/headers/meson.build7
1 files changed, 6 insertions, 1 deletions
diff --git a/test/headers/meson.build b/test/headers/meson.build
index af270073..0c4e97ea 100644
--- a/test/headers/meson.build
+++ b/test/headers/meson.build
@@ -6,7 +6,6 @@ header_c_suppressions = []
if get_option('strict')
if cc.get_id() == 'clang'
header_c_suppressions += [
- '-Wno-nullability-extension',
'-Wno-padded',
]
elif cc.get_id() == 'gcc'
@@ -21,6 +20,12 @@ if get_option('strict')
endif
endif
+if cc.get_id() == 'clang'
+ header_c_suppressions += [
+ '-Wno-nullability-extension',
+ ]
+endif
+
test(
'headers',
executable(