aboutsummaryrefslogtreecommitdiffstats
path: root/test/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build18
1 files changed, 18 insertions, 0 deletions
diff --git a/test/meson.build b/test/meson.build
index e8392559..67907c25 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -77,6 +77,14 @@ if get_option('utils')
bad_args = [
['/no/such/file'],
['ftp://unsupported.org'],
+ ['-F', '', '-G', ''],
+ ['-F'],
+ ['-F', '?s ?p ?o . ?q ?r ?s .', '-s', ''],
+ ['-F', '?s ?p ?o .\n?q ?r ?s .\n', '-s', ''],
+ ['-F', 'bad_pattern', '-s', ''],
+ ['-G'],
+ ['-G', '?s ?p ?o . ?q ?r ?s .', '-s', ''],
+ ['-G', 'bad_pattern', '-s', ''],
['-I'],
['-c'],
['-i', 'unknown'],
@@ -135,6 +143,16 @@ if get_option('utils')
env: test_env,
suite: ['serdi', 'options'])
+ test('filter', files('test_filter.py'),
+ args: script_args,
+ env: test_env,
+ suite: ['serdi', 'options'])
+
+ test('grep', files('test_grep.py'),
+ args: script_args,
+ env: test_env,
+ suite: ['serdi', 'options'])
+
# Inputs
test('stdin', files('test_stdin.py'),