aboutsummaryrefslogtreecommitdiffstats
path: root/tools/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'tools/meson.build')
-rw-r--r--tools/meson.build13
1 files changed, 13 insertions, 0 deletions
diff --git a/tools/meson.build b/tools/meson.build
new file mode 100644
index 00000000..3054364a
--- /dev/null
+++ b/tools/meson.build
@@ -0,0 +1,13 @@
+tool_c_args = c_warnings + platform_args + prog_args
+tool_link_args = []
+
+if get_option('static')
+ tool_link_args += ['-static']
+endif
+
+serdi = executable('serdi',
+ ['serdi.c', 'console.c'],
+ c_args: tool_c_args,
+ link_args: tool_link_args,
+ install: true,
+ dependencies: serd_dep)