aboutsummaryrefslogtreecommitdiffstats
path: root/tools/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'tools/meson.build')
-rw-r--r--tools/meson.build32
1 files changed, 26 insertions, 6 deletions
diff --git a/tools/meson.build b/tools/meson.build
index 3054364a..d4964784 100644
--- a/tools/meson.build
+++ b/tools/meson.build
@@ -5,9 +5,29 @@ if get_option('static')
tool_link_args += ['-static']
endif
-serdi = executable('serdi',
- ['serdi.c', 'console.c'],
- c_args: tool_c_args,
- link_args: tool_link_args,
- install: true,
- dependencies: serd_dep)
+tools = [
+ 'filter',
+ 'pipe',
+ 'sort',
+]
+
+serd_filter = executable('serd-filter',
+ ['serd-filter.c', 'console.c'],
+ c_args: tool_c_args,
+ link_args: tool_link_args,
+ install: true,
+ dependencies: serd_dep)
+
+serd_pipe = executable('serd-pipe',
+ ['serd-pipe.c', 'console.c'],
+ c_args: tool_c_args,
+ link_args: tool_link_args,
+ install: true,
+ dependencies: serd_dep)
+
+serd_sort = executable('serd-sort',
+ ['serd-sort.c', 'console.c'],
+ c_args: tool_c_args,
+ link_args: tool_link_args,
+ install: true,
+ dependencies: serd_dep)