summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build11
1 files changed, 6 insertions, 5 deletions
diff --git a/meson.build b/meson.build
index 29c8467..9154289 100644
--- a/meson.build
+++ b/meson.build
@@ -328,13 +328,14 @@ if qt6_dep.found()
)
endif
-#########
-# Tests #
-#########
+########
+# Lint #
+########
+
+if get_option('lint')
-if get_option('warning_level') == 'everything'
- # Check release metadata
if not meson.is_subproject()
+ # Check release metadata
autoship = find_program('autoship', required: false)
if autoship.found()
test('autoship', autoship, args: ['test', suil_src_root], suite: 'data')