summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build33
1 files changed, 17 insertions, 16 deletions
diff --git a/meson.build b/meson.build
index 31937a7..94847dd 100644
--- a/meson.build
+++ b/meson.build
@@ -1,16 +1,19 @@
# Copyright 2021-2022 David Robillard <d@drobilla.net>
# SPDX-License-Identifier: 0BSD OR ISC
-project('suil', ['c', 'cpp'],
- version: '0.10.19',
- license: 'ISC',
- meson_version: '>= 0.56.0',
- default_options: [
- 'b_ndebug=if-release',
- 'buildtype=release',
- 'c_std=c99',
- 'cpp_std=c++14',
- ])
+project(
+ 'suil',
+ ['c', 'cpp'],
+ default_options: [
+ 'b_ndebug=if-release',
+ 'buildtype=release',
+ 'c_std=c99',
+ 'cpp_std=c++14',
+ ],
+ license: 'ISC',
+ meson_version: '>= 0.56.0',
+ version: '0.10.19',
+)
suil_src_root = meson.current_source_dir()
major_version = meson.project_version().split('.')[0]
@@ -320,9 +323,7 @@ if get_option('warning_level') == 'everything'
# Check licensing metadata
reuse = find_program('reuse', required: false)
if reuse.found()
- test('REUSE', reuse,
- args: ['--root', suil_src_root, 'lint'],
- suite: 'data')
+ test('REUSE', reuse, args: ['--root', suil_src_root, 'lint'], suite: 'data')
endif
endif
@@ -338,9 +339,9 @@ endif
if not meson.is_subproject()
summary(
{
- 'Install prefix': get_option('prefix'),
- 'Headers': get_option('prefix') / get_option('includedir'),
- 'Libraries': get_option('prefix') / get_option('libdir'),
+ 'Install prefix': get_option('prefix'),
+ 'Headers': get_option('prefix') / get_option('includedir'),
+ 'Libraries': get_option('prefix') / get_option('libdir'),
},
section: 'Directories',
)