aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 5 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index dd01dc8..8d3152c 100644
--- a/meson.build
+++ b/meson.build
@@ -30,7 +30,11 @@ if get_option('strict')
endif
cpp_suppressions = []
- if cpp.get_id() == 'gcc'
+ if cpp.get_id() == 'clang'
+ cpp_suppressions += [
+ '-Wno-padded',
+ ]
+ elif cpp.get_id() == 'gcc'
cpp_suppressions += [
'-Wno-effc++',
'-Wno-volatile',