summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAndy Wingo <wingo@pobox.com>2001-12-26 06:49:47 +0000
committerAndy Wingo <wingo@pobox.com>2001-12-26 06:49:47 +0000
commit21de09a438bd3858bd47705cbfbcb7562c2fbe6b (patch)
tree548a3a23deb5c97cbf356d076e9829fbad84d3d7 /configure.ac
parent31bd0ef9c4765eb4b4caa65b18afa6935b6c4633 (diff)
downloadgst-plugins-bad-21de09a438bd3858bd47705cbfbcb7562c2fbe6b.tar.gz
gst-plugins-bad-21de09a438bd3858bd47705cbfbcb7562c2fbe6b.tar.bz2
gst-plugins-bad-21de09a438bd3858bd47705cbfbcb7562c2fbe6b.zip
muahahahaha. gstreamer-compprep initializes every plugin so it's a good way of figuring out plugin issues. it spits o...
Original commit message from CVS: muahahahaha. gstreamer-compprep initializes every plugin so it's a good way of figuring out plugin issues. it spits out no more errors now.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 11 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index f1179a5b..3c808045 100644
--- a/configure.ac
+++ b/configure.ac
@@ -73,15 +73,17 @@ dnl # Super Duper options for plugin building #
dnl ###########################################
dnl experimental plugins; stuff that hasn't had the dust settle yet
-
+dnl read 'builds, but might not work'
GST_CHECK_FEATURE(EXPERIMENTAL, [enable building of experimental plugins],,
[HAVE_EXPERIMENTAL=yes],disabled,
[
AC_MSG_WARN(building experimental plugins)
USE_LIBMIKMOD="yes"
+ USE_SMOOTHWAVE="yes"
],[
AC_MSG_NOTICE(not building experimental plugins)
USE_LIBMIKMOD="no"
+ USE_SMOOTHWAVE="no"
])
dnl broken plugins; stuff that doesn't seem to build at the moment
@@ -287,7 +289,7 @@ GST_PLUGINS_ALL="\
median mpeg1enc mpeg1sys mpeg2enc mpeg2sub\
mpegaudio mpegaudioparse mpegstream mpegtypes\
passthrough playondemand rtjpeg silence sine\
- smooth smoothwave spectrum speed stereo stereomono\
+ smooth spectrum speed stereo stereomono\
synaesthesia udp videoscale volenv volume vumeter wavparse y4m"
AC_SUBST(GST_PLUGINS_ALL)
@@ -596,6 +598,12 @@ GST_CHECK_FEATURE(SHOUT, [shout plugin], icecastsend, [
AC_SUBST(SHOUT_LIBS)
])
+dnl *** smoothwave ***
+translit(dnm, m, l) AM_CONDITIONAL(USE_SMOOTHWAVE, true)
+GST_CHECK_FEATURE(SMOOTHWAVE, [smoothwave plugin], smoothwave, [
+ if test $HAVE_GTK = "yes"; then HAVE_SMOOTHWAVE=yes; fi;
+])
+
dnl for sidplay
dnl FIXME : make this work
dnl AC_PATH_LIBSIDPLAY
@@ -1020,7 +1028,6 @@ gst/rtjpeg/Makefile
gst/silence/Makefile
gst/sine/Makefile
gst/smooth/Makefile
-gst/smoothwave/Makefile
gst/spectrum/Makefile
gst/speed/Makefile
gst/stereo/Makefile
@@ -1070,6 +1077,7 @@ ext/rtp/Makefile
ext/sdl/Makefile
ext/shout/Makefile
ext/sidplay/Makefile
+ext/smoothwave/Makefile
ext/vorbis/Makefile
ext/xmms/Makefile
gst-libs/Makefile