summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas Vander Stichele <thomas@apestaart.org>2001-12-20 20:37:57 +0000
committerThomas Vander Stichele <thomas@apestaart.org>2001-12-20 20:37:57 +0000
commit3f74c3928fa2b44667952a4ce247eca7c6563f39 (patch)
tree95b1430861770da6f9f13f83ddb758d51244063e /configure.ac
parent3d06875b167d3ad0f3fc78299a326d55e4290787 (diff)
downloadgst-plugins-bad-3f74c3928fa2b44667952a4ce247eca7c6563f39.tar.gz
gst-plugins-bad-3f74c3928fa2b44667952a4ce247eca7c6563f39.tar.bz2
gst-plugins-bad-3f74c3928fa2b44667952a4ce247eca7c6563f39.zip
added v4l handling
Original commit message from CVS: added v4l handling
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 6 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 6037801e..1e079ac7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -416,6 +416,12 @@ GST_CHECK_FEATURE(OSS, [OSS audio], osssrc osssink, [
AC_CHECK_HEADER(sys/soundcard.h, HAVE_OSS="yes", HAVE_OSS="no")
])
+dnl *** Video 4 Linux ***
+translit(dnm, m, l) AM_CONDITIONAL(USE_V4L, true)
+GST_CHECK_FEATURE(V4L, [Video 4 Linux], v4lsrc, [
+ AC_CHECK_HEADER(linux/videodev.h, HAVE_V4L="yes", HAVE_V4L="no")
+])
+
dnl *** VGA ***
translit(dnm, m, l) AM_CONDITIONAL(USE_VGA, true)
GST_CHECK_FEATURE(VGA, [VGA], vgavideosink, [
@@ -762,11 +768,6 @@ AC_CHECK_HEADER(linux/cdrom.h,
HAVE_LINUX_CDROM=yes, HAVE_LINUX_CDROM=no
)
-dnl Check for linux/videodev.h
-AC_CHECK_HEADER(linux/videodev.h,
- HAVE_LINUX_VIDEODEV=yes, HAVE_LINUX_VIDEODEV=no
-)
-
dnl ######################################################################
dnl # Check command line parameters, and set shell variables accordingly #