summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas Vander Stichele <thomas@apestaart.org>2001-12-23 12:18:18 +0000
committerThomas Vander Stichele <thomas@apestaart.org>2001-12-23 12:18:18 +0000
commit953f0e2f01cbff2f521024b33e489e966ed356bb (patch)
tree98d9b466174657129c4cb005419a640ee181852f /configure.ac
parent0d4f573fc103544c7972485b010072eda52a0e4b (diff)
downloadgst-plugins-bad-953f0e2f01cbff2f521024b33e489e966ed356bb.tar.gz
gst-plugins-bad-953f0e2f01cbff2f521024b33e489e966ed356bb.tar.bz2
gst-plugins-bad-953f0e2f01cbff2f521024b33e489e966ed356bb.zip
made changes everywhere to accomodate for the headers being in <gst/(lib)/...> we'll need to conclude this fast becau...
Original commit message from CVS: made changes everywhere to accomodate for the headers being in <gst/(lib)/...> we'll need to conclude this fast because we will also need to change stuff in core real soon for the libs in order to fix everything and I can't do it right now because I disabled all of the plugins here ;)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 3 insertions, 17 deletions
diff --git a/configure.ac b/configure.ac
index ba6888c3..e16dc673 100644
--- a/configure.ac
+++ b/configure.ac
@@ -519,7 +519,8 @@ GST_CHECK_FEATURE(LIBMIKMOD, [mikmod plugin], mikmod, [
dnl *** mpeg2dec ***
translit(dnm, m, l) AM_CONDITIONAL(USE_MPEG2DEC, true)
GST_CHECK_FEATURE(MPEG2DEC, [mpeg2dec], mpeg2dec, [
- GST_CHECK_LIBHEADER(MPEG2DEC, mpeg2, mpeg2_init,, mpeg2dec/mpeg2.h, MPEG2DEC_LIBS="-lmpeg2")
+ GST_CHECK_LIBHEADER(MPEG2DEC, mpeg2, mpeg2_init,, mpeg2dec/mpeg2.h, MPEG2DEC_LIBS="-lmpeg2 -lmpeg2dec")
+ AC_SUBST(MPEG2DEC_LIBS)
])
dnl *** quicktime ***
@@ -863,19 +864,6 @@ if test "x$HAVE_LIBDVDREAD" = xyes; then
AC_DEFINE(HAVE_LIBDVDREAD)
fi
-dnl FIXME: I think these can go
-if test "x$HAVE_LINUX_CDROM" = xyes; then
- AC_DEFINE(HAVE_LINUX_CDROM)
-fi
-
-if test "x$HAVE_LINUX_VIDEODEV" = xyes; then
- AC_DEFINE(HAVE_LINUX_VIDEODEV)
-fi
-
-if test "x$HAVE_MPEG2DEC" = xyes; then
- AC_DEFINE(HAVE_MPEG2DEC)
-fi
-
if test "x$HAVE_A52DEC" = xyes; then
AC_DEFINE(HAVE_A52DEC)
fi
@@ -907,8 +895,6 @@ AM_CONDITIONAL(EXPERIMENTAL, test "$EXPERIMENTAL" = "$xyes")
AM_CONDITIONAL(BROKEN, test "$BROKEN" = "$xyes")
AM_CONDITIONAL(HAVE_LIBMIKMOD, test "x$HAVE_LIBMIKMOD" = "xyes")
-AM_CONDITIONAL(HAVE_LINUX_CDROM, test "x$HAVE_LINUX_CDROM" = "xyes")
-AM_CONDITIONAL(HAVE_LINUX_VIDEODEV, test "x$HAVE_LINUX_VIDEODEV" = "xyes")
AM_CONDITIONAL(HAVE_LIBDVDREAD, test "x$HAVE_LIBDVDREAD" = "xyes")
AM_CONDITIONAL(HAVE_LIBJPEG, test "x$HAVE_LIBJPEG" = "xyes")
AM_CONDITIONAL(HAVE_LIBSDL, test "x$HAVE_LIBSDL" = "xyes")
@@ -929,7 +915,6 @@ AM_CONDITIONAL(HAVE_FIG2DEV_PNG, $HAVE_FIG2DEV_PNG)
AM_CONDITIONAL(HAVE_FIG2DEV_PDF, $HAVE_FIG2DEV_PDF)
AM_CONDITIONAL(HAVE_CDPARANOIA, test "x$HAVE_CDPARANOIA" = "xyes")
AM_CONDITIONAL(HAVE_LIBSHOUT, test "x$HAVE_LIBSHOUT" = "xyes")
-AM_CONDITIONAL(HAVE_MPEG2DEC, test "x$HAVE_MPEG2DEC" = "xyes")
AM_CONDITIONAL(HAVE_A52DEC, test "x$HAVE_A52DEC" = "xyes")
AM_CONDITIONAL(HAVE_AVIFILE, test "x$HAVE_AVIFILE" = "xyes")
dnl thomas : the next line gives errors, this is how it is in CVS
@@ -1104,6 +1089,7 @@ gst-libs/Makefile
gst-libs/gst/Makefile
gst-libs/gst/audio/Makefile
gst-libs/gst/resample/Makefile
+gst-libs/gst/riff/Makefile
gst-plugins.spec
)