summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAndy Wingo <wingo@pobox.com>2001-12-22 00:19:17 +0000
committerAndy Wingo <wingo@pobox.com>2001-12-22 00:19:17 +0000
commitb5e6695c90169396be333c19a9aed45d0a192c86 (patch)
treec7084871bfe693978c7061897d6ad97764660b9e /configure.ac
parente4aa0c30675a23e14c39fa12eb919aa59af775a4 (diff)
downloadgst-plugins-bad-b5e6695c90169396be333c19a9aed45d0a192c86.tar.gz
gst-plugins-bad-b5e6695c90169396be333c19a9aed45d0a192c86.tar.bz2
gst-plugins-bad-b5e6695c90169396be333c19a9aed45d0a192c86.zip
the xvideo check looks for -lXv_pic first, another virtual patch from taaz
Original commit message from CVS: the xvideo check looks for -lXv_pic first, another virtual patch from taaz
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 9a16544d..2a71e19d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -81,7 +81,7 @@ GST_CHECK_FEATURE(EXPERIMENTAL, [enable building of experimental plugins],,
USE_LIBMIKMOD="yes"
USE_ARTS="yes"
USE_ARTSC="yes"
- USE_SINE="no"
+ USE_SINE="yes"
],[
AC_MSG_NOTICE(not building experimental plugins)
USE_LIBMIKMOD="no"
@@ -397,7 +397,11 @@ GST_CHECK_FEATURE(VGA, [VGA], vgavideosink, [
dnl *** XVideo ***
translit(dnm, m, l) AM_CONDITIONAL(USE_XVIDEO, true)
GST_CHECK_FEATURE(XVIDEO, [X11 XVideo extensions], xvideosink, [
- GST_CHECK_LIBHEADER(XVIDEO, Xv, XvQueryExtension, $X_LIBS $X_PRE_LIBS -lXext -lX11 $X_EXTRA_LIBS, X11/extensions/Xvlib.h)
+ dnl look for the PIC library first, debian likes it
+ GST_CHECK_LIBHEADER(XVIDEO, Xv_pic, XvQueryExtension, $X_LIBS $X_PRE_LIBS -lXext -lX11 $X_EXTRA_LIBS, X11/extensions/Xvlib.h)
+ if test "x$HAVE_XVIDEO" = "no"; then
+ GST_CHECK_LIBHEADER(XVIDEO, Xv, XvQueryExtension, $X_LIBS $X_PRE_LIBS -lXext -lX11 $X_EXTRA_LIBS, X11/extensions/Xvlib.h)
+ fi
])
dnl Next, check for the optional libraries: