summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorErik Walthinsen <omega@temple-baptist.org>2002-02-03 03:57:04 +0000
committerErik Walthinsen <omega@temple-baptist.org>2002-02-03 03:57:04 +0000
commit2bba9ef04ecaa53f2437726bb4d15c3592fe4c00 (patch)
tree55664bdadfb91554269c736b698e78142f959311 /configure.ac
parent88d7ce008052f929c843afb3e7a6c258ed26c2c3 (diff)
downloadgst-plugins-bad-2bba9ef04ecaa53f2437726bb4d15c3592fe4c00.tar.gz
gst-plugins-bad-2bba9ef04ecaa53f2437726bb4d15c3592fe4c00.tar.bz2
gst-plugins-bad-2bba9ef04ecaa53f2437726bb4d15c3592fe4c00.zip
Committing differences between CVS and the 0.3.2 release. These changes were in the local copy that the dist was mad...
Original commit message from CVS: Committing differences between CVS and the 0.3.2 release. These changes were in the local copy that the dist was made from, but have never been in CVS (I hunted for matching revisions on all of them). I will retag these files with the proper release tag as soon as they're committed.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 12 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 732fb261..e84d4da7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -205,7 +205,7 @@ GST_PLUGINS_ALL="\
mpegaudio mpegaudioparse mpegstream mpegtypes\
passthrough playondemand rtjpeg silence sine\
smooth spectrum speed stereo stereomono\
- synaesthesia udp videoscale volenv volume vumeter wavparse y4m goom"
+ synaesthesia udp videoscale volenv volume vumeter wavparse y4m"
AC_SUBST(GST_PLUGINS_ALL)
@@ -489,6 +489,17 @@ GST_CHECK_FEATURE(JPEG, [jpeg], jpegenc jpegdec, [
AC_SUBST(JPEG_LIBS)
])
+dnl *** jpeg-mmx ***
+AC_ARG_WITH(jpeg-mmx-path, [ --with-jpeg-mmx-path, path to mmx accelerated jpeg lib])
+translit(dnm, m, l) AM_CONDITIONAL(USE_JPEG_MMX, true)
+GST_CHECK_FEATURE(JPEG_MMX, [jpeg-mmx], jpegmmxenc jpegmmxdec, [
+ AC_CHECK_LIB(jpeg-mmx, jpeg_start_compress, HAVE_JPEG_MMX="yes", HAVE_JPEG_MMX="no", "-L$with_jpeg_mmx_path")
+ JPEG_MMX_LIBS="-L$with_jpeg_mmx_path -ljpeg-mmx"
+ JPEG_MMX_CFLAGS="-I$with_jpeg_mmx_path"
+ AC_SUBST(JPEG_MMX_LIBS)
+ AC_SUBST(JPEG_MMX_CFLAGS)
+])
+
dnl *** mad ***
dnl FIXME: we could use header checks here as well IMO
translit(dnm, m, l) AM_CONDITIONAL(USE_MAD, true)
@@ -783,7 +794,6 @@ gst/volume/Makefile
gst/vumeter/Makefile
gst/wavparse/Makefile
gst/y4m/Makefile
-gst/goom/Makefile
sys/Makefile
sys/oss/Makefile
sys/qcam/Makefile