summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas Vander Stichele <thomas@apestaart.org>2003-02-03 14:01:14 +0000
committerThomas Vander Stichele <thomas@apestaart.org>2003-02-03 14:01:14 +0000
commitc1434a0fe7eb3df584bd9821c5ef46b160c4dfd8 (patch)
treea9359f8f65189f449dedba5fb5808dc798285498 /configure.ac
parent353361f49d3a02ac488830ad0bc254209592a849 (diff)
downloadgst-plugins-bad-c1434a0fe7eb3df584bd9821c5ef46b160c4dfd8.tar.gz
gst-plugins-bad-c1434a0fe7eb3df584bd9821c5ef46b160c4dfd8.tar.bz2
gst-plugins-bad-c1434a0fe7eb3df584bd9821c5ef46b160c4dfd8.zip
also slurp ffmpeg if source is missing
Original commit message from CVS: also slurp ffmpeg if source is missing
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 11 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index a8598199..727b34d5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -540,8 +540,17 @@ GST_CHECK_FEATURE(FFMPEG, [ffmpeg plug-ins], ffmpeg, [
AS_SLURP_FFMPEG(gst-libs/ext/ffmpeg, 2002-12-14 12:00 GMT,
HAVE_FFMPEG=yes, HAVE_FFMPEG=no)
else
- AC_MSG_NOTICE(FFmpeg CVS code should be included already)
- HAVE_FFMPEG=yes
+ # if not in CVS mode, check if we have the files and force checkout
+ # if we don't
+ FFMPEG_FILE=$srcdir/gst-libs/ext/ffmpeg/ffmpeg/configure
+ if test -f $FFMPEG_FILE; then
+ AC_MSG_NOTICE(FFmpeg CVS code should be included already)
+ HAVE_FFMPEG=yes
+ else
+ AC_MSG_NOTICE(slurping missing FFmpeg CVS source)
+ AS_SLURP_FFMPEG(gst-libs/ext/ffmpeg, 2002-12-14 12:00 GMT,
+ HAVE_FFMPEG=yes, HAVE_FFMPEG=no)
+ fi
fi
# we only bother with uninstalled (included) ffmpeg for now
AC_DEFINE_UNQUOTED(HAVE_FFMPEG_UNINSTALLED, 1,