summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorSteve Baker <steve@stevebaker.org>2002-04-25 19:43:31 +0000
committerSteve Baker <steve@stevebaker.org>2002-04-25 19:43:31 +0000
commite2f2d7f2d2257a8a52114fedaf9105e72548c8cc (patch)
tree7cb2e58aae4705a7637bc9695ec2ad75da5d33e0 /configure.ac
parent8f42abeb7b19991b5bef8faba1a6326139fe69db (diff)
downloadgst-plugins-bad-e2f2d7f2d2257a8a52114fedaf9105e72548c8cc.tar.gz
gst-plugins-bad-e2f2d7f2d2257a8a52114fedaf9105e72548c8cc.tar.bz2
gst-plugins-bad-e2f2d7f2d2257a8a52114fedaf9105e72548c8cc.zip
check for lrint and lrintf - a new header in gst/floatcast/floatcast.h will check for this and provide alternatives i...
Original commit message from CVS: check for lrint and lrintf - a new header in gst/floatcast/floatcast.h will check for this and provide alternatives if necessary
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 99d8e14a..ffd2f7a0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -612,6 +612,10 @@ main() { atomic_t t; atomic_set(&t,0); atomic_inc(&t); atomic_add(1,&t);return 0
])
fi
+dnl Check for fast float to int casting as defined in C99
+AC_C99_FUNC_LRINT()
+AC_C99_FUNC_LRINTF()
+
dnl ######################################################################
dnl # Check command line parameters, and set shell variables accordingly #
dnl ######################################################################