summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorBrian Cameron <brian.cameron@sun.com>2003-07-15 12:39:39 +0000
committerBrian Cameron <brian.cameron@sun.com>2003-07-15 12:39:39 +0000
commit0e04196b7136fee8628669a769838ecf78416dea (patch)
treee73c7233348bf8af3e1f9d59796e7324f11628c8 /configure.ac
parent1c4eb87d8aad344eb5886c519e6fede5049f216a (diff)
downloadgst-plugins-bad-0e04196b7136fee8628669a769838ecf78416dea.tar.gz
gst-plugins-bad-0e04196b7136fee8628669a769838ecf78416dea.tar.bz2
gst-plugins-bad-0e04196b7136fee8628669a769838ecf78416dea.zip
Now set XVIDEO_LIBS only if the Xv library is found. Fixed matroska check so that it doesn't stop the configure if i...
Original commit message from CVS: Now set XVIDEO_LIBS only if the Xv library is found. Fixed matroska check so that it doesn't stop the configure if it fails.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 13 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 8f78d7bc..57f2e3e5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -425,17 +425,23 @@ GST_CHECK_FEATURE(XVIDEO, [X11 XVideo extensions], xvideosink-Xv, [
AC_CHECK_LIB(Xv_pic, XvQueryExtension,
HAVE_XVIDEO="yes", HAVE_XVIDEO="no",
$X_LIBS $X_PRE_LIBS -lXext -lX11 $X_EXTRA_LIBS)
- XVIDEO_LIBS="-lXv_pic -lXext"
- dnl try again using something else if we didn't find it first
- if test x$HAVE_XVIDEO = xno; then
- AC_CHECK_LIB(Xv, XvQueryExtension,
+ if test x$HAVE_XVIDEO = xyes; then
+ XVIDEO_LIBS="-lXv_pic -lXext"
+ AC_SUBST(XVIDEO_LIBS)
+ else
+ dnl try again using something else if we didn't find it first
+ if test x$HAVE_XVIDEO = xno; then
+ AC_CHECK_LIB(Xv, XvQueryExtension,
HAVE_XVIDEO="yes", HAVE_XVIDEO="no",
$X_LIBS $X_PRE_LIBS -lXext -lX11 $X_EXTRA_LIBS)
- XVIDEO_LIBS="-lXv -lXext"
- fi
- AC_SUBST(XVIDEO_LIBS)
+ if test x$HAVE_XVIDEO = xyes; then
+ XVIDEO_LIBS="-lXv -lXext"
+ AC_SUBST(XVIDEO_LIBS)
+ fi
+ fi
+ fi
fi
])