summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRonald S. Bultje <rbultje@ronald.bitfreak.net>2003-07-14 17:37:34 +0000
committerRonald S. Bultje <rbultje@ronald.bitfreak.net>2003-07-14 17:37:34 +0000
commit1c4eb87d8aad344eb5886c519e6fede5049f216a (patch)
tree99c279d581416bff846500fbd8ac3cb015892074 /configure.ac
parentfc44c4515c7ca1a516ce223f335ba01094f014bd (diff)
downloadgst-plugins-bad-1c4eb87d8aad344eb5886c519e6fede5049f216a.tar.gz
gst-plugins-bad-1c4eb87d8aad344eb5886c519e6fede5049f216a.tar.bz2
gst-plugins-bad-1c4eb87d8aad344eb5886c519e6fede5049f216a.zip
Add matroska support to the build tree
Original commit message from CVS: Add matroska support to the build tree
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 11 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 80da6143..8f78d7bc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -666,7 +666,7 @@ GST_CHECK_FEATURE(FFMPEG, [ffmpeg plug-ins], ffmpeg, [
# prerelease and release should get it disted
if test "x$GST_PLUGINS_VERSION_NANO" = x1; then
AC_MSG_NOTICE(slurping FFmpeg CVS source)
- AS_SLURP_FFMPEG(gst-libs/ext/ffmpeg, 2003-06-09 22:00 GMT,
+ AS_SLURP_FFMPEG(gst-libs/ext/ffmpeg, 2003-07-05 22:00 GMT,
HAVE_FFMPEG=yes, HAVE_FFMPEG=no)
else
AC_MSG_NOTICE(FFmpeg CVS code should be included already)
@@ -832,6 +832,15 @@ GST_CHECK_FEATURE(MAD, [mad mp3 decoder], mad, [
])
AC_SUBST(MAD_LIBS)
+dnl *** matroska ***
+translit(dnm, m, l) AM_CONDITIONAL(USE_MATROSKA, true)
+GST_CHECK_FEATURE(MATROSKA, [matroska muxer/demuxer], matroska muxer/demuxer, [
+ PATH_EBML([HAVE_MATROSKA=yes], [HAVE_MATROSKA=no])
+ if test x$HAVE_MATROSKA = xyes; then
+ PATH_MATROSKA(0.4.4, [HAVE_MATROSKA=yes], [HAVE_MATROSKA=no])
+ fi
+])
+
dnl *** mikmod ***
translit(dnm, m, l) AM_CONDITIONAL(USE_MIKMOD, true)
GST_CHECK_FEATURE(MIKMOD, [mikmod plug-in], mikmod, [
@@ -1237,6 +1246,7 @@ ext/libfame/Makefile
ext/libpng/Makefile
ext/mad/Makefile
ext/mas/Makefile
+ext/matroska/Makefile
ext/mikmod/Makefile
ext/mpeg2dec/Makefile
ext/pango/Makefile