summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.net>2007-01-05 14:02:33 +0000
committerTim-Philipp Müller <tim@centricular.net>2007-01-05 14:02:33 +0000
commit289b30d543210633ff1b09fa4eac0c89913a9b54 (patch)
tree2722af627bd0e3fd309b01d8aefbb49c57d1bf8a /configure.ac
parenta59bef232b5e88b419a9b0be974ebc02a3bca9b9 (diff)
downloadgst-plugins-bad-289b30d543210633ff1b09fa4eac0c89913a9b54.tar.gz
gst-plugins-bad-289b30d543210633ff1b09fa4eac0c89913a9b54.tar.bz2
gst-plugins-bad-289b30d543210633ff1b09fa4eac0c89913a9b54.zip
configure.ac: Don't compile rfbsource if we don't have sys/socket.h.
Original commit message from CVS: * configure.ac: Don't compile rfbsource if we don't have sys/socket.h. Should fix compilation on MingW.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3ca71e9e..8edc8a9c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -231,6 +231,17 @@ if test "x$HAVE_CPU_I386" != "xyes" || test "xHAVE_CPU_X86_64" = "xyes"; then
AC_MSG_WARN([Not building real plugin, only works on 32bit x86 platforms])
GST_PLUGINS_SELECTED=`echo $GST_PLUGINS_SELECTED | sed 's/real//g'`
fi
+
+dnl disable gst plugins we might not be able to build on this
+dnl platform: librfb (ugly but minimally invasive)
+dnl FIXME: maybe move to sys, or make work with winsock2
+AC_CHECK_HEADERS([sys/socket.h], HAVE_SYS_SOCKET_H=yes)
+AC_CHECK_HEADERS([winsock2.h], HAVE_WINSOCK2_H=yes)
+
+if test "x$HAVE_SYS_SOCKET_H" != "xyes"; then
+ GST_PLUGINS_SELECTED=`echo $GST_PLUGINS_SELECTED | $SED -e s/librfb//`
+fi
+
AC_SUBST(GST_PLUGINS_SELECTED)