summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.net>2008-01-26 12:11:47 +0000
committerTim-Philipp Müller <tim@centricular.net>2008-01-26 12:11:47 +0000
commit3a5db6a93221b15b23ae593d55f3cdc7e4f2804a (patch)
tree28a3efcfb09495be3808e0ffc86311d1def62582 /configure.ac
parent9e31b57dc37cb94761ab3aa98018c6f9bc496e0c (diff)
downloadgst-plugins-bad-3a5db6a93221b15b23ae593d55f3cdc7e4f2804a.tar.gz
gst-plugins-bad-3a5db6a93221b15b23ae593d55f3cdc7e4f2804a.tar.bz2
gst-plugins-bad-3a5db6a93221b15b23ae593d55f3cdc7e4f2804a.zip
configure.ac: Check for libglade-2.0, for the metadata-editor example.
Original commit message from CVS: * configure.ac: Check for libglade-2.0, for the metadata-editor example. * tests/icles/Makefile.am: Only try to build the metadata-editor example if we have gtk and glade (otherwise the build would just fail ...); fix build in uninstalled setup. * tests/icles/metadata_editor.c: (on_cell_edited), (ui_add_columns): Fix compiler warnings (use GLib macros to cast pointer <-> int).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 58c2c379..66992b06 100644
--- a/configure.ac
+++ b/configure.ac
@@ -245,6 +245,14 @@ AC_SUBST(GTK_CFLAGS)
AC_SUBST(HAVE_GTK)
AM_CONDITIONAL(HAVE_GTK, test "x$HAVE_GTK" = "xyes")
+dnl libglade is optional and only used in examples
+HAVE_GLADE=NO
+PKG_CHECK_MODULES(GLADE, libglade-2.0 >= 2.6.0, HAVE_GLADE=yes, HAVE_GLADE=no)
+AC_SUBST(GLADE_LIBS)
+AC_SUBST(GLADE_CFLAGS)
+AC_SUBST(HAVE_GLADE)
+AM_CONDITIONAL(HAVE_GLADE, test "x$HAVE_GLADE" = "xyes")
+
dnl set license and copyright notice
GST_LICENSE="LGPL"
AC_DEFINE_UNQUOTED(GST_LICENSE, "$GST_LICENSE", [GStreamer license])