summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristophe Fergeau <teuf@gnome.org>2006-03-09 17:44:17 +0000
committerChristophe Fergeau <teuf@gnome.org>2006-03-09 17:44:17 +0000
commit47575c6de1d0513cbdecff7647acb514ad53184f (patch)
treea089838a6bbeec4f0ff630c3bee8f3b135f229e8 /configure.ac
parent6ece4976ccf84bbe355ef854581c19f5c776de31 (diff)
downloadgst-plugins-bad-47575c6de1d0513cbdecff7647acb514ad53184f.tar.gz
gst-plugins-bad-47575c6de1d0513cbdecff7647acb514ad53184f.tar.bz2
gst-plugins-bad-47575c6de1d0513cbdecff7647acb514ad53184f.zip
new id3v2 muxer based on TagLib
Original commit message from CVS: 2006-03-09 Christophe Fergeau <teuf@gnome.org> reviewed by: Tim-Philipp Müller <tim at centricular dot net> * configure.ac: * ext/Makefile.am: * ext/taglib/Makefile.am: * ext/taglib/gsttaglib.cc: * ext/taglib/gsttaglib.h: new id3v2 muxer based on TagLib
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e67f046f..87fca060 100644
--- a/configure.ac
+++ b/configure.ac
@@ -649,6 +649,14 @@ int main () { return 0; }
], )
])
+dnl *** taglib ***
+translit(dnm, m, l) AM_CONDITIONAL(USE_TAGLIB, true)
+GST_CHECK_FEATURE(TAGLIB, [taglib ID3v2 tag writer], taglib, [
+ PKG_CHECK_MODULES(TAGLIB, taglib >= 1.4, HAVE_TAGLIB="yes", HAVE_TAGLIB="no")
+ AC_SUBST(TAGLIB_CFLAGS)
+ AC_SUBST(TAGLIB_LIBS)
+])
+
dnl also add builddir include for enumtypes and marshal
GST_CFLAGS="-I\$(top_srcdir)/gst-libs -I\$(top_builddir)/gst-libs $GST_CFLAGS $GST_ERROR"
@@ -738,6 +746,7 @@ ext/divx/Makefile
ext/musepack/Makefile
ext/sdl/Makefile
ext/swfdec/Makefile
+ext/taglib/Makefile
ext/xvid/Makefile
docs/Makefile
docs/plugins/Makefile