summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEdgard Lima <edgard.lima@indt.org.br>2005-11-08 13:55:13 +0000
committerEdgard Lima <edgard.lima@indt.org.br>2005-11-08 13:55:13 +0000
commit5df1c827fbca23bdd07e6c6c0cc0f03a2dc29b26 (patch)
treeb16ac49af6f980e43faed754f043e1d3fb41deb2 /configure.ac
parent7a50084e34bf69694ba3544b03b52917df0cc91a (diff)
downloadgst-plugins-bad-5df1c827fbca23bdd07e6c6c0cc0f03a2dc29b26.tar.gz
gst-plugins-bad-5df1c827fbca23bdd07e6c6c0cc0f03a2dc29b26.tar.bz2
gst-plugins-bad-5df1c827fbca23bdd07e6c6c0cc0f03a2dc29b26.zip
Ported to 0.9. Some issues to be solved yet: 1- set correct timestamps 2- seg fault when eos 3- seek is now disabled
Original commit message from CVS: Ported to 0.9. Some issues to be solved yet: 1- set correct timestamps 2- seg fault when eos 3- seek is now disabled
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9bdaaba7..b2fdddf5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -409,6 +409,19 @@ GST_CHECK_FEATURE(SDL, [SDL plug-in], sdlvideosink, [
fi
])
+dnl *** ivorbis ***
+dnl AM_PATH_IVORBIS only takes two options
+translit(dnm, m, l) AM_CONDITIONAL(USE_IVORBIS, true)
+GST_CHECK_FEATURE(IVORBIS, [integer vorbis plug-in], ivorbisdec, [
+ IVORBIS_LIBS=
+ IVORBIS_CFLAGS=
+ AC_CHECK_LIB(vorbisidec, vorbis_block_init,
+ [IVORBIS_LIBS=-lvorbisidec
+ HAVE_IVORBIS=yes],
+ HAVE_IVORBIS=no)
+ AC_SUBST(IVORBIS_LIBS)
+ AC_SUBST(IVORBIS_CFLAGS)
+])
dnl *** gsm ***
translit(dnm, m, l) AM_CONDITIONAL(USE_GSM, true)
@@ -496,6 +509,7 @@ ext/Makefile
ext/directfb/Makefile
ext/faac/Makefile
ext/faad/Makefile
+ext/ivorbis/Makefile
ext/gsm/Makefile
ext/sdl/Makefile
docs/Makefile