summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEdgard Lima <edgard.lima@indt.org.br>2005-11-29 02:55:18 +0000
committerEdgard Lima <edgard.lima@indt.org.br>2005-11-29 02:55:18 +0000
commit85d3362e3426775100ac58890709f15bbabd49f3 (patch)
tree34653e7583b158734fbe4f8b7244185758b72197 /configure.ac
parent07e2ec5f9574095e71c2208779c719574bb135ab (diff)
downloadgst-plugins-bad-85d3362e3426775100ac58890709f15bbabd49f3.tar.gz
gst-plugins-bad-85d3362e3426775100ac58890709f15bbabd49f3.tar.bz2
gst-plugins-bad-85d3362e3426775100ac58890709f15bbabd49f3.zip
libmm ported to 0.9. It works fine, but print some error messages. I'll fix them soon. Tested with mmssrc location=m...
Original commit message from CVS: libmm ported to 0.9. It works fine, but print some error messages. I'll fix them soon. Tested with mmssrc location=mms:// ! filesink.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ce1fcea5..eb9ad1f5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -411,6 +411,14 @@ GST_CHECK_FEATURE(MUSEPACK, [musepackdec], musepack, [
AC_LANG_C
])
+dnl *** libmms ***
+translit(dnm, m, l) AM_CONDITIONAL(USE_LIBMMS, true)
+GST_CHECK_FEATURE(LIBMMS, [mms protocol library], libmms, [
+ dnl check with pkg-config first
+ PKG_CHECK_MODULES(LIBMMS, libmms >= 0.1, HAVE_LIBMMS="yes", HAVE_LIBMMS="no")
+])
+AC_SUBST(LIBMMS_LIBS)
+
dnl *** SDL ***
translit(dnm, m, l) AM_CONDITIONAL(USE_SDL, true)
@@ -530,6 +538,7 @@ ext/faad/Makefile
ext/wavpack/Makefile
ext/ivorbis/Makefile
ext/gsm/Makefile
+ext/libmms/Makefile
ext/musepack/Makefile
ext/sdl/Makefile
docs/Makefile