summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorSebastian Dröge <slomo@circular-chaos.org>2008-01-10 12:36:46 +0000
committerSebastian Dröge <slomo@circular-chaos.org>2008-01-10 12:36:46 +0000
commit868b72c9a3b624231fd36fb6fe68ecac8584f9af (patch)
tree7cf7797d05d29c7a7fb32314d6fe514f5d167a0f /configure.ac
parent8fc6e320d065e28896b22539b28b5c8208054207 (diff)
downloadgst-plugins-bad-868b72c9a3b624231fd36fb6fe68ecac8584f9af.tar.gz
gst-plugins-bad-868b72c9a3b624231fd36fb6fe68ecac8584f9af.tar.bz2
gst-plugins-bad-868b72c9a3b624231fd36fb6fe68ecac8584f9af.zip
autogen.sh: Add -Wno-portability to the automake parameters to stop warnings about GNU make extensions being used. We...
Original commit message from CVS: * autogen.sh: Add -Wno-portability to the automake parameters to stop warnings about GNU make extensions being used. We require GNU make in almost every Makefile anyway. * configure.ac: Use AM_PROG_CC_C_O as a compiler that accepts both -c and -o at the same time is required for per target flags.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9caf9dcd..1b0d08bd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -150,6 +150,9 @@ AC_CHECK_PROG(HAVE_CXX, $CXX, yes, no)
AS_PROG_OBJC
+dnl check if the compiler supports '-c' and '-o' options
+AM_PROG_CC_C_O
+
AC_PATH_PROG(VALGRIND_PATH, valgrind, no)
AM_CONDITIONAL(HAVE_VALGRIND, test ! "x$VALGRIND_PATH" = "xno")