summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJames Doc Livingston <doclivingston@gmail.com>2006-05-03 11:27:42 +0000
committerTim-Philipp Müller <tim@centricular.net>2006-05-03 11:27:42 +0000
commit9107cd5b6fc4ebac2587ca16ba7a695fcd641194 (patch)
treed2dc1401cffd9e7202dc8c267b508e880aa0515b /configure.ac
parentf910e0f4a58505251af8308fa33f646de8d7e5fe (diff)
downloadgst-plugins-bad-9107cd5b6fc4ebac2587ca16ba7a695fcd641194.tar.gz
gst-plugins-bad-9107cd5b6fc4ebac2587ca16ba7a695fcd641194.tar.bz2
gst-plugins-bad-9107cd5b6fc4ebac2587ca16ba7a695fcd641194.zip
Port MusicBrainz TRM plugin (#336898).
Original commit message from CVS: Patch by: James "Doc" Livingston <doclivingston gmail com> * configure.ac: * ext/musicbrainz/Makefile.am: * ext/musicbrainz/gsttrm.c: (gst_trm_base_init), (gst_trm_class_init), (gst_trm_init), (gst_trm_setcaps), (gst_trm_chain), (gst_trm_emit_signature), (gst_trm_set_property), (gst_trm_get_property), (gst_trm_change_state), (plugin_init): * ext/musicbrainz/gsttrm.h: Port MusicBrainz TRM plugin (#336898).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ff6704b4..ac851c4e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -481,6 +481,14 @@ GST_CHECK_FEATURE(MUSEPACK, [musepackdec], musepack, [
AC_LANG_C
])
+dnl *** musicbrainz ***
+translit(dnm, m, l) AM_CONDITIONAL(USE_MUSICBRAINZ, true)
+GST_CHECK_FEATURE(MUSICBRAINZ, [musicbrainz tag generation], musicbrainz, [
+ PKG_CHECK_MODULES(MUSICBRAINZ, libmusicbrainz >= 2.1.0, HAVE_MUSICBRAINZ="yes", HAVE_MUSICBRAINZ="no")
+ AC_SUBST(MUSICBRAINZ_CFLAGS)
+ AC_SUBST(MUSICBRAINZ_LIBS)
+])
+
dnl *** neon ***
translit(dnm, m, l) AM_CONDITIONAL(USE_NEON, true)
GST_CHECK_FEATURE(NEON, [neon http client plugins], neonhttpsrc, [
@@ -648,6 +656,7 @@ ext/ivorbis/Makefile
ext/libmms/Makefile
ext/Makefile
ext/musepack/Makefile
+ext/musicbrainz/Makefile
ext/neon/Makefile
ext/sdl/Makefile
ext/soundtouch/Makefile